2008年11月30日

Eclipse3.4とTomcat6

Eclipse3.4でTomcat6が認識されない問題が発生したので、そのメモ。

Eclipse3.4では、
[ウィンド] → [ビューの表示] → [サーバー]
で、インストールしているTomcatをサーバーとして登録することができます。
eclipse3.4_tomcat6_05.png

しかし、Tomcat6をインストール後に、Eclipseを起動し、「新規サーバーを定義しようとすると以下のように「Tomcat v6.0 サーバー」が指定できない状態になります。
eclipse3.4_tomcat6_01.png

この原因は、デフォルトでインストールされたTomcat 6.0のtomcat-users.xmlの文字コードが「cp932」になっているからです。これをutf-8に変更すると、Eclipseでの新規サーバーの定義で、Tomcat 6.0が選択可能になります。

Windows用Tomcat6はデフォルトで以下の場所にインストールされるので、その中の conf/tomcat-users.xmlを開き encoding="cp932" を encoding="utf-8" と変更します。
C:\Program Files\Apache Software Foundation\Tomcat 6.0


上記の変更後、新規サーバーの定義で「Tomcat v6.0 サーバー」が選択可能になります。
eclipse3.4_tomcat6_02.png
posted by jun1 at 23:21| Comment(0) | TrackBack(0) | Java
この記事へのコメント
コメントを書く
お名前:

メールアドレス:

ホームページアドレス:

コメント:

この記事へのトラックバックURL
http://blog.sakura.ne.jp/tb/23637301

この記事へのトラックバック